« 初詣 | メイン | R-4C 雑感 »

2009年1月 4日(日)

USBasp


 正月休みの間に何か一つだけでも完成させようというのと、ちょっと目的があったのとで、一年半も前にJN3XBY岩永さんに分けていただいてたままになってたUSB版AVRライタを組むことにしました。

 基板や主要部品だけでなく、抵抗から果てはFRISKの空ケースまで、有り難いことであります。


 プリント基板に


 穴開けなんて何年ぶりかな? 後生大事に持ってるサンハヤトミニドリル専用ACアダプタが壊れてたんで乾電池運用です。


 それにしても、パターン面から部品を載せるのが難しいのは意外でした。スイッチやLEDなど足が下にあるものは、先につけておかないと後からでは相当苦労するハメに。

 写真ではジャンパ線を一本忘れてます。


 そのジャンパをもちろん接続し、いそいそとUSBに突っ込んでみるのですが…残念ながらデバイスドライバをインストールできません。何でか原因不明。


 強制的に更新しようとしても、こんなメッセージが出て拒否されます。

 うーん、ソフトが悪いのか半田づけが悪いのか、はたまた部品を壊してしもぅたんか…それはないと思いますが、今のところ失敗の巻となってしまいました(>_<)

投稿者 ji3kdh : 2009年1月 4日(日) 18:50 カテゴリ : 自作 タグ :

トラックバック

このエントリーのトラックバックURL:
http://www.2333.net/~ji3kdh/weblog/mttb_m26.cgi/859/tb/

トラックバックスパム防止のため、トラックバックURLの末尾に、上記画像の数字列を続けて入力の上でご利用下さい。
お手数をおかけいたしますが、よろしくお願い申し上げます。

コメント

本年も宜しくお願いします。
昨年暮にGPSモジュールを落札してしまいました。
10KHz出力付きなので外部PLLで10MHzを作らねばなりません。その為に10MHzのVCXOが必用になりますが手持ちにありません。その為まだ何もしていません。どう考えてもPLLで1レベル精度が落ちそうです。

さてUSBですが、先日外付けHD(USB接続用)を使おうと本体前面のUSBポートに接続しましたが、認識してくれませんでした。背面のポートに接続したら認識しました。
こんなこともあるものだという思いでした。
参考にならないかもしれませんが。

ますますの御活躍を祈念しております。

投稿者 JA2NKD/1 松浦 : 2009年1月 5日(月) 11:50

電源が入っていないとか。
USBのD+とD-が逆とか。
ATmega8にプログラムが書かれていないとか。
はてさて…

投稿者 居酒屋ガレージ店主(JH3DBO) : 2009年1月 5日(月) 14:02

 松浦さん、こちらこそ本年もどうぞよろしくお願いいたします。そしてついにGPSを入手なさいましたか! また新たな記事を楽しみにいたしております。しかし10kHz出力とは存じませんでした。10kHzから10MHzを制御するとなると、素人考えでもだいぶ精度が落ちそうな気がしますね。世間には10MHz出力のあるGPS装置をよく見かけますが、それらも基本は一緒なんでしょうか?

 USBについてありがとうございます。体験したことはありませんがそのような話を小生も聞いたことがありましたので、あっちこっちに差してみました。

 下間さん、今回はWindows上でのデバイスドライバの登録なので、ターゲットはまだなくていいはずなんです。それからD+とD-の入れ替えも、まさかとは思いながら百均のケーブルやし念のためにとやってみたんですが、デバイス名(USBasp)が出なくなるなどかえって悪くなったので、極性はあっていそうなんです。プログラムの一部が消えた…いや、それはないですよね。データ線のどれかが接触不良(ハンダ不良)と考えるのが自然かな。でも「ハードウェア情報がありません」ってどういう意味なんでしょうねぇ。ちゃんと通信できんかったらこうなるんかな。

 ちょっと時間を空けてから見直してみます。

投稿者 JI3KDH 杉山 : 2009年1月 5日(月) 21:52

杉山さん、こんにちは。
気になる点をいくつか、確認ください。

(1)マイコンの裏側に1箇所ジャンパー線が必要ですが、接続されてますでしょうか?
(2)写真では、ジャンパー線が見えませんが、接続されてますでしょうか?(コメントされてますので、OKだと思いますが)

現状でUSBaspが表示されているようなので、上記は大丈夫だとは思いますが。

次に、ソフトのインストールは、当局の下記サイトを参考にされてますでしょうか?
http://qrp-homebrewers.net/usbasp.aspx

ソフトのインストールでハードウェアのウィザードにおいてusbaspのwin-driverのフォルダを指定する必要があります。
サイトでもコメントしてありますが、LibUSB-Win32がインストールされて無い場合、その必要があります。
それも、確認ください。
デバイスマネージャーでUSBaspが見えるようになればいいのですが・・・・。
参考になりますでしょうか?

投稿者 jn3xby@岩永 : 2009年1月10日(土) 15:41

 岩永さん、ご無沙汰いたしております。ノーサポートのお約束でしたのに、ありがとうございます!

> 1)マイコンの裏側に1箇所ジャンパー線が必要ですが、接続されてますでしょうか?

 はい、ICの下はあとからでは難しそうでしたので忘れず一番に接続しました。

> (2)写真では、ジャンパー線が見えませんが、接続されてますでしょうか?(コメントされてますので、OKだと思いますが)

 これ実は最初忘れたままノートPCに接続しました。これが悪かったのかな…もちろん今は接続しております。

> 現状でUSBaspが表示されているようなので、上記は大丈夫だとは思いますが。

 さらに白状しますと、USBaspの文字列が出るのはデスクトップ2台だけでして、最初に接続したノートではそれすら出ません。

> 次に、ソフトのインストールは、当局の下記サイトを参考にされてますでしょうか?
http://qrp-homebrewers.net/usbasp.aspx

 はい、何度も読み返させていただいております。

> ソフトのインストールでハードウェアのウィザードにおいてusbaspのwin-driverのフォルダを指定する必要があります。
サイトでもコメントしてありますが、LibUSB-Win32がインストールされて無い場合、その必要があります。
それも、確認ください。

 はい、ドライバの場所指定方法は間違ってないと思います。ただ3台のパソコンとも、最初はLibUSB-Win32がない状態で接続しました。そのあたりの形跡がレジストリに残っているのかな…だとすると、消すのがちょっとやっかいですね。もちろん今はインストールしてあります。

> デバイスマネージャーでUSBaspが見えるようになればいいのですが・・・・。

 デバイスマネージャ上ではドライバが認識されていないよため、「?」だったり「不明なデバイス」だったりして、USBaspの文字列が残念ながら出ていません。

 最初ジャンパを忘れてたのがまずかったような感じもしてまいりましたね…

投稿者 JI3KDH 杉山 : 2009年1月10日(土) 22:24

コメントはこちら↓からどうぞ




保存しますか?


認証キー を入力して下さい→

コメントの投稿ボタンを押してから反応があるまで、通常30〜60秒かかります。
省エネサーバで運用しておりますので、気長にお待ちいただければ幸いです(^^)